TippingPoint Zero Day Initiative
 

WebKit.org Webkit Array.Splice Remote Code Execution Vulnerability

ZDI-12-067: April 18th, 2012

CVE ID

CVSS Score

Affected Vendors

Affected Products

    WebKit

Vulnerability Details


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of WebKit.
User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The flaw exists within the JavaScriptCore component as used by WebKit. This module is responsible for the in browser implementation of JavaScript. When handling the array.splice method the browser improperly calculates the length, and thus allocation size for the newly modified array. A remote attacker can exploit this vulnerability to execute arbitrary code under the context of the browser.

Vendor Response

WebKit.Org has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2011-12-22 - Vulnerability reported to vendor
    2012-04-18 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    Alexander Gavrun