TippingPoint Zero Day Initiative
 

Apache httpd mod_status Heap Buffer Overflow Remote Code Execution Vulnerability

ZDI-14-236: July 16th, 2014

CVE ID

CVSS Score

Affected Vendors

    Apache

Affected Products

    HTTPD Server 2.x

Vulnerability Details


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Apache HTTPD server. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the updating of mod_status. A race condition in mod_status allows an attacker to disclose information or corrupt memory with several requests to endpoints with handler server-status and other endpoints. By abusing this flaw, an attacker can possibly disclose credentials or leverage this situation to achieve remote code execution.

Vendor Response

Apache has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2014-05-30 - Vulnerability reported to vendor
    2014-07-16 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    AKAT-1
    22733db72ab3ed94b5f8a1ffcde850251fe6f466
    Marek Kroemeke