TippingPoint Zero Day Initiative
 

ManageEngine OpManager DataComparisionServlet query SQL Remote Code Execution Vulnerability

ZDI-15-141: April 15th, 2015

CVE ID

CVSS Score

Affected Vendors

Affected Products

TippingPoint™ IPS Customer Protection

TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 16566. For further product information on the TippingPoint IPS:

Vulnerability Details


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of ManageEngine OpManager. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the DataComparisonServlet servlet. The issue lies in the ability to execute arbitrary SQL statements. An attacker could leverage this vulnerability to execute code under the context of the database, which defaults to SYSTEM.

Vendor Response

ManageEngine has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2014-08-18 - Vulnerability reported to vendor
    2015-04-15 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    Andrea Micalizzi (rgod)