TippingPoint Zero Day Initiative
 

Foxit Reader FlateDecode Use-After-Free Remote Code Execution Vulnerability

ZDI-16-221: March 23rd, 2016

CVE ID

CVSS Score

Affected Vendors

Affected Products

Vulnerability Details


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Foxit Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within FlateDecode. A specially crafted PDF with a specific FlateDecode stream can force a dangling pointer to be reused after it has been freed. An attacker could leverage this vulnerability to execute arbitrary code under the context of the current process.

Vendor Response

Foxit has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2016-02-16 - Vulnerability reported to vendor
    2016-03-23 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    Jaanus Kp
    Clarified Security