Advisory Details

July 19th, 2007

Ipswitch IMail IMAP Daemon SUBSCRIBE Stack Overflow Vulnerability

ZDI-07-043
ZDI-CAN-179

CVE ID CVE-2007-2795
CVSS SCORE
AFFECTED VENDORS Ipswitch
AFFECTED PRODUCTS IMail
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 2068. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows attackers to execute arbitrary code on vulnerable installations of Ipswitch IMail and ICS server. Authentication is required to exploit this vulnerability.

The specific flaw exists due to a lack of bounds checking during the
parsing of arguments to the SUBSCRIBE IMAP command sent to the IMAP daemon listening by default on TCP port 143. By providing an overly long string as the argument, an exploitable stack-based buffer overflow occurs.

VENDOR RESPONSE Ipswitch has issued an update to correct this vulnerability. More details can be found at:
http://www.ipswitch.com/support/imail/releases/im200621.asp
DISCLOSURE TIMELINE
  • 2007-03-09 - Vulnerability reported to vendor
  • 2007-07-19 - Coordinated public release of advisory
CREDIT Sebastian Apelt (webmaster@buzzworld.org)
BACK TO ADVISORIES