Advisory Details

March 26th, 2008

Novell eDirectory for Linux LDAP delRequest Stack Overflow Vulnerability

ZDI-08-013
ZDI-CAN-214

CVE ID CVE-2008-0924
CVSS SCORE
AFFECTED VENDORS Novell
AFFECTED PRODUCTS eDirectory
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 5547. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell eDirectory for Linux. Authentication is not required to exploit this vulnerability.

The specific flaw exists in the libnldap library. When a large LDAP delRequest message is sent, a stack overflow occurs overwriting a function pointer. This results in a situation allowing the execution of arbitrary code.

ADDITIONAL DETAILS Novell has issued an update to correct this vulnerability. More details can be found at:
http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=3382120&sliceId=SAL_Public&dialogID=59352034&stateId=0%200%2059350122
DISCLOSURE TIMELINE
  • 2007-07-20 - Vulnerability reported to vendor
  • 2008-03-26 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES