Advisory Details

October 13th, 2009

Adobe Reader Compact Font Format Malformed Index Memory Corruption Vulnerability

ZDI-09-073
ZDI-CAN-479

CVE ID CVE-2009-2985
CVSS SCORE
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Acrobat
Reader
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 8658. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Adobe Acrobat and Adobe Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists when the application parses a PDF file containing a malformed Compact Font Format stream. While decoding the font embedded in this stream, the application will explicitly trust a 16-bit value used to index into an array of elements. Usage of the object later will cause heap corruption which can be leveraged to achieve code execution under the context of the current user.

VENDOR RESPONSE Adobe has issued an update to correct this vulnerability. More details can be found at:
http://www.adobe.com/support/security/bulletins/apsb09-15.html
DISCLOSURE TIMELINE
  • 2009-04-28 - Vulnerability reported to vendor
  • 2009-10-13 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES