Advisory Details

August 5th, 2010

Novell iPrint Client Browser Plugin operation Parameter Remote Code Execution Vulnerability

ZDI-10-140
ZDI-CAN-754

CVE ID CVE-2010-4315
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Novell
AFFECTED PRODUCTS iPrint
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 9917. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of the Novell iPrint Client Browser Plugin. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within handling plugin parameters. Specifically, a long value for the operation parameter can trigger a stack-based buffer overflow. Successful exploitation leads to execution of arbitrary code under the context of the user running the browser process.

VENDOR RESPONSE Novell has issued an update to correct this vulnerability. More details can be found at:
http://download.novell.com/Download?buildid=ftwZBxEFjIg~
DISCLOSURE TIMELINE
  • 2010-06-02 - Vulnerability reported to vendor
  • 2010-08-05 - Coordinated public release of advisory
CREDIT Ivan Rodriguez Almuina
BACK TO ADVISORIES