Advisory Details

December 9th, 2010

Mozilla Firefox nsDOMAttribute MutationObserver Remote Code Execution Vulnerability

ZDI-10-264
ZDI-CAN-898

CVE ID CVE-2010-3766
CVSS SCORE 9, (AV:N/AC:L/Au:N/C:P/I:P/A:C)
AFFECTED VENDORS Mozilla Firefox
AFFECTED PRODUCTS 3.6.x
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Mozilla Firefox. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the application's support of the NodeIterator API used for element traversal. Due to a particular element not implementing functionality required by the API, a use-after free vulnerability can be forced to occur. This can be used to achieve code execution under the context of the application.

VENDOR RESPONSE Mozilla Firefox has issued an update to correct this vulnerability. More details can be found at:
http://www.mozilla.org/security/announce/2010/mfsa2010-80.html
DISCLOSURE TIMELINE
  • 2010-08-25 - Vulnerability reported to vendor
  • 2010-12-09 - Coordinated public release of advisory
CREDIT regenrecht
BACK TO ADVISORIES