Advisory Details

February 8th, 2011

Adobe Reader Controlled memset Remote Code Execution Vulnerability

ZDI-11-065
ZDI-CAN-842

CVE ID CVE-2011-0567
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Reader
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Adobe Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within AcroRd32.dll. Initially, a pointer passed to memset can be miscalculated and the resulting copy operation corrupts heap memory. Later, the application attempts to use the modified data which can be leveraged to execute arbitrary code under the context of the user invoking the Reader application.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
http://www.adobe.com/support/security/bulletins/apsb11-03.html
DISCLOSURE TIMELINE
  • 2010-06-30 - Vulnerability reported to vendor
  • 2011-02-08 - Coordinated public release of advisory
CREDIT Abdullah Ada
BACK TO ADVISORIES