Advisory Details

March 18th, 2011

Novell Netware NWFTPD.NLM DELE Remote Code Execution Vulnerability

ZDI-11-106
ZDI-CAN-940

CVE ID CVE-2010-4228
CVSS SCORE 9, (AV:N/AC:L/Au:S/C:C/I:C/A:C)
AFFECTED VENDORS Novell
AFFECTED PRODUCTS Netware
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 10659. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell Netware. Authentication is required to exploit this vulnerability.

The flaw exists within NWFTPD.NLM. When handling the argument provided to the DELE command the application copies user supplied data to a fixed length stack buffer. A remote attacker can exploit this vulnerability to execute arbitrary code under the context of the super user.

ADDITIONAL DETAILS Novell has issued an update to correct this vulnerability. More details can be found at:
http://download.novell.com/Download?buildid=Ax6AbxwGLTs~
DISCLOSURE TIMELINE
  • 2010-09-22 - Vulnerability reported to vendor
  • 2011-03-18 - Coordinated public release of advisory
CREDIT Francis Provencher for Protek Research Lab's
BACK TO ADVISORIES