Advisory Details

June 14th, 2011

Adobe Shockwave Font Structure Parsing Remote Code Execution Vulnerability

ZDI-11-217
ZDI-CAN-1055

CVE ID CVE-2011-2109
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Shockwave Player
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 11371. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of the Adobe Shockwave Player. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the Font Asset.x32 module responsible for parsing font-related structures within Director movies (.dir). The code within this module extracts and copies strings without any bounds checking. Several calls to strcpy can be abused to overwrite stack buffers and subsequently execute remote code under the context of the user running the browser.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
http://www.adobe.com/support/security/bulletins/apsb11-17.html
DISCLOSURE TIMELINE
  • 2011-04-01 - Vulnerability reported to vendor
  • 2011-06-14 - Coordinated public release of advisory
CREDIT Sebastian Apelt (www.siberas.de)
BACK TO ADVISORIES