Advisory Details

June 29th, 2011

Apple Quicktime Apple Lossless Audio Codec Parsing Remote Code Execution Vulnerability

ZDI-11-230
ZDI-CAN-1140

CVE ID CVE-2011-0211
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS Quicktime
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 11428. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Apple Quicktime. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the way Quicktime handles Apple Lossless Audio Codec streams. While parsing the sample description for the 'alac' codec an integer wrap can occur that results in the allocation of a memory buffer that is smaller than intended. When Quicktime writes to this buffer it causes a memory corruption that can lead to remote code execution under the context of the current user.

VENDOR RESPONSE Apple has issued an update to correct this vulnerability. More details can be found at:
http://support.apple.com/kb/HT4723
DISCLOSURE TIMELINE
  • 2011-04-11 - Vulnerability reported to vendor
  • 2011-06-29 - Coordinated public release of advisory
CREDIT Luigi Auriemma
Damian Put
BACK TO ADVISORIES