Advisory Details

May 30th, 2013

Apple Safari Array Indexing Remote Code Execution Vulnerability

ZDI-13-107
ZDI-CAN-1704

CVE ID CVE-2013-0997
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS Safari
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 12935. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Webkit. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of JSArray objects. The issue lies in the usage of a custom sort comparison function. By manipulating a JSArray object an attacker can force controlled memory to be accessed. An attacker can lever this vulnerability to execute code under the context of the current process.

ADDITIONAL DETAILS Apple has issued an update to correct this vulnerability. More details can be found at:
http://support.apple.com/kb/HT1222
DISCLOSURE TIMELINE
  • 2013-01-07 - Vulnerability reported to vendor
  • 2013-05-30 - Coordinated public release of advisory
CREDIT Vitaliy Toropov
BACK TO ADVISORIES