Advisory Details

January 10th, 2014

Hewlett-Packard Data Protector Backup Client Service EXEC_BAR Remote Code Execution Vulnerability

ZDI-14-008
ZDI-CAN-1885

CVE ID CVE-2013-2347
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Hewlett-Packard
AFFECTED PRODUCTS Data Protector
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute remote code on vulnerable installations of HP Data Protector. Authentication is not required to exploit this vulnerability.

This specific flaw exists in the Backup Client Service (OmniInet.exe). The Backup Client Service listens on TCP port 5555 for communications between systems in the cell. The process has insufficient sanitization on user-supplied data when handling certain messages. Remote, unauthenticated attackers can exploit this vulnerability by sending malicious EXEC_BAR packet to the target that results in an arbitrary command execution in the context of the SYSTEM user.

ADDITIONAL DETAILS Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at:
https://h20566.www2.hp.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c03822422
DISCLOSURE TIMELINE
  • 2013-05-24 - Vulnerability reported to vendor
  • 2014-01-10 - Coordinated public release of advisory
CREDIT Aniway.Anyway@gmail.com
BACK TO ADVISORIES