Advisory Details

June 30th, 2014

Foxit PDF SDK DLL FPDFBookmark_GetTitle Buffer Overflow Remote Code Execution Vulnerability

ZDI-14-214
ZDI-CAN-1983

CVE ID CVE-2014-4646
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Foxit
AFFECTED PRODUCTS Foxit PDF SDK DLL
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on software built with vulnerable versions of the Foxit SDK. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the FPDFBookmark_GetTitle() function. An error in evaluating the safety of the copy allows for an attacker to overflow the provided buffer in some circumstances. An attacker can leverage this vulnerability to execute arbitrary code in the context of the current process.

ADDITIONAL DETAILS Foxit has issued an update to correct this vulnerability. More details can be found at:
http://www.foxitsoftware.com/support/security_bulletins.php#FRD-20
DISCLOSURE TIMELINE
  • 2014-04-22 - Vulnerability reported to vendor
  • 2014-06-30 - Coordinated public release of advisory
CREDIT John Leitch
BACK TO ADVISORIES