Advisory Details

October 1st, 2014

Sophos Cyberoam add_guest_user Blind SQL Injection Remote Code Execution Vulnerability

ZDI-14-329
ZDI-CAN-2331

CVE ID CVE-2014-5503
CVSS SCORE 8.5, (AV:N/AC:L/Au:N/C:P/I:N/A:C)
AFFECTED VENDORS Sophos
AFFECTED PRODUCTS Cyberoam
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 16276. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary SQL on vulnerable installations of Sophos Cyberoam. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the add_guest_user opcode. The issue lies in the failure to properly sanitize the specified mobile number prior to executing a SQL query. A remote attacker can leverage this vulnerability to disclose credentials and possibly leverage this situation to achieve remote code execution.

ADDITIONAL DETAILS Sophos has issued an update to correct this vulnerability. More details can be found at:
http://kb.cyberoam.com/default.asp?id=3049&Lang=1&SID
DISCLOSURE TIMELINE
  • 2014-06-04 - Vulnerability reported to vendor
  • 2014-10-01 - Coordinated public release of advisory
CREDIT agix
BACK TO ADVISORIES