Advisory Details

December 9th, 2014

Lexmark MarkVision Enterprise GfdFileUploadServlet Remote Code Execution Vulnerability

ZDI-14-410
ZDI-CAN-2437

CVE ID CVE-2014-8741
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Lexmark
AFFECTED PRODUCTS MarkVision Enterprise
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 16688. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Lexmark MarkVision Enterprise. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the GfdFileUploadServlet class. The class contains a method that does not properly sanitize input allowing for directory traversal. An attacker can leverage this vulnerability to write files under the context of SYSTEM and achieve remote code execution.

ADDITIONAL DETAILS Lexmark has issued an update to correct this vulnerability. More details can be found at:
http://support.lexmark.com/index?page=content&id=TE666&locale=EN&userlocale=EN_US
DISCLOSURE TIMELINE
  • 2014-11-03 - Vulnerability reported to vendor
  • 2014-12-09 - Coordinated public release of advisory
CREDIT Andrea Micalizzi (rgod)
BACK TO ADVISORIES