Advisory Details

December 11th, 2014

ManageEngine Password Manager Pro UploadAccountActivities filename Directory Traversal Denial of Service Vulnerability

ZDI-14-421
ZDI-CAN-2473

CVE ID CVE-2014-9372
CVSS SCORE 6.4, (AV:N/AC:L/Au:N/C:N/I:P/A:P)
AFFECTED VENDORS ManageEngine
AFFECTED PRODUCTS Password Manager Pro
VULNERABILITY DETAILS


This vulnerability allows remote attackers to create a denial of service condition on vulnerable installations of ManageEngine Password Manager Pro. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the UploadAccountActivities servlet. The issue lies in the failure to properly sanitize a filename. A remote attacker can exploit this vulnerability to delete files from the system.

ADDITIONAL DETAILS ManageEngine has issued an update to correct this vulnerability. More details can be found at:
http://www.manageengine.com/products/passwordmanagerpro/release-notes.html
DISCLOSURE TIMELINE
  • 2014-08-18 - Vulnerability reported to vendor
  • 2014-12-11 - Coordinated public release of advisory
CREDIT Andrea Micalizzi (rgod)
BACK TO ADVISORIES