Advisory Details

February 10th, 2015

Persistent Systems Client Automation Remote Elevation of Privilege Vulnerability

ZDI-15-039
ZDI-CAN-1916

CVE ID CVE-2015-1498
CVSS SCORE 9, (AV:N/AC:L/Au:S/C:C/I:C/A:C)
AFFECTED VENDORS Persistent Systems
AFFECTED PRODUCTS Radia Client Automation
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Persistent Systems Client Automation. Authentication is required to exploit this vulnerability.

The specific flaw exists within the handling of certain requests (including getUsers, addAssigneesToRole, and removeAssigneesFromRole). Incomplete authentication allows for crafted packets to enumerate the users on the system and change the roles of users on the system without valid credentials. By using this, an attacker with access to any valid account on the system is able to execute arbitrary code on all clients controlled by the system.

ADDITIONAL DETAILS Persistent Systems has issued an update to correct this vulnerability. More details can be found at:
https://radiasupport.accelerite.com/hc/en-us/articles/203659814-Accelerite-releases-solutions-and-best-practices-to-enhance-the-security-for-RBAC-and-Remote-Notify-features
DISCLOSURE TIMELINE
  • 2014-04-16 - Vulnerability reported to vendor
  • 2015-02-10 - Coordinated public release of advisory
CREDIT Andrea Micalizzi aka rgod
BACK TO ADVISORIES