Advisory Details

April 29th, 2015

AlienVault Unified Security Management Plugin Remote Code Execution Vulnerability

ZDI-15-161
ZDI-CAN-2630

CVE ID CVE-2015-3446
CVSS SCORE 9.3, (AV:N/AC:M/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS AlienVault
AFFECTED PRODUCTS Unified Security Management
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of AlienVault Unified Security Management. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the AlienVault framework daemon which permits remote unauthenticated changes to its .cfg file. A specially crafted plugin configuration file can specify a custom function which can contain arbitrary Python code. An attacker can exploit this condition to achieve code execution under the context of the root user.

ADDITIONAL DETAILS AlienVault has issued an update to correct this vulnerability. More details can be found at:
https://www.alienvault.com/forums/discussion/4415/
DISCLOSURE TIMELINE
  • 2015-01-06 - Vulnerability reported to vendor
  • 2015-04-29 - Coordinated public release of advisory
CREDIT Spencer McIntyre
BACK TO ADVISORIES