Advisory Details

May 12th, 2015

Adobe Acrobat Pro Spell customDictionaryExport Information Disclosure Vulnerability

ZDI-15-211
ZDI-CAN-2706

CVE ID CVE-2015-3058
CVSS SCORE 5.0, (AV:N/AC:L/Au:N/C:P/I:N/A:N)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Acrobat Pro
VULNERABILITY DETAILS


This vulnerability allows remote attackers to leak memory addresses from Spell.api on vulnerable installations of Adobe Acrobat Pro. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the Spell object. By creating and exporting a custom dictionary, it is possible to leak memory addresses from Spell.api. An attacker can leverage this vulnerability to disclose arbitrary memory.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
https://helpx.adobe.com/security/products/reader/apsb15-10.html
DISCLOSURE TIMELINE
  • 2015-01-27 - Vulnerability reported to vendor
  • 2015-05-12 - Coordinated public release of advisory
CREDIT AbdulAziz Hariri - HP Zero Day Initiative
BACK TO ADVISORIES