Advisory Details

May 26th, 2015

Arcserve Unified Data Protection Management Service exportServlet Directory Traversal Information Disclosure and Denial of Service Vulnerability

ZDI-15-242
ZDI-CAN-2810

CVE ID CVE-2015-4068
CVSS SCORE 9.4, (AV:N/AC:L/Au:N/C:C/I:N/A:C)
AFFECTED VENDORS Arcserve
AFFECTED PRODUCTS Unified Data Protection
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 19699. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to disclose and delete files on vulnerable installations of Arcserve Unified Data Protection. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the exportServlet servlet. The issue lies in the failure to sanitize the path of files requested. An attacker could use this to create an information disclosure and denial-of-service condition under the context of the SYSTEM user.

VENDOR RESPONSE Arcserve has issued an update to correct this vulnerability. More details can be found at:
http://documentation.arcserve.com/Arcserve-UDP/Available/V5/ENU/Bookshelf_Files/HTML/Update%204/UDP_Update4_ReleaseNotes.html
DISCLOSURE TIMELINE
  • 2015-04-03 - Vulnerability reported to vendor
  • 2015-05-26 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES