Advisory Details

June 30th, 2015

IBM Tivoli Storage Manager FastBack Server Opcode 1364 Stack Buffer Overflow Remote Code Execution Vulnerability

ZDI-15-270
ZDI-CAN-2808

CVE ID CVE-2015-1948
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS IBM
AFFECTED PRODUCTS Tivoli Storage Manager FastBack
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of IBM Tivoli Storage Manager FastBack. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the processing of opcode 1364. By sending a crafted packet on TCP port 11460, an attacker is able to cause a stack buffer overflow. An attacker can use this to execute arbitrary code under the context of SYSTEM.

VENDOR RESPONSE IBM has issued an update to correct this vulnerability. More details can be found at:
http://www-01.ibm.com/support/docview.wss?uid=swg21959398
DISCLOSURE TIMELINE
  • 2015-04-23 - Vulnerability reported to vendor
  • 2015-06-30 - Coordinated public release of advisory
CREDIT Lola Montez
BACK TO ADVISORIES