Advisory Details

July 14th, 2015

NetIQ Security Solutions for ISeries NetIQExecObject.NetIQExec.1 SafeShellExecute Stack Buffer Overflow Remote Code Execution Vulnerability

ZDI-15-340
ZDI-CAN-2699

CVE ID CVE-2015-0795
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS NetIQ
AFFECTED PRODUCTS Security Solutions for ISeries
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 19439. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of NetIQ Security Solutions for ISeries. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the NetIQExecObject.NetIQExec.1 ActiveX Control. By providing overly long arguments to the SafeShellExecute function, an attacker can overflow fixed size stack buffers and execute arbitrary code in the context of the browser.

VENDOR RESPONSE NetIQ has issued an update to correct this vulnerability. More details can be found at:
http://www.netiq.com/support/7016656
DISCLOSURE TIMELINE
  • 2015-01-27 - Vulnerability reported to vendor
  • 2015-07-14 - Coordinated public release of advisory
CREDIT Andrea Micalizzi (rgod)
BACK TO ADVISORIES