Advisory Details

October 20th, 2015

SAP 3D Visual Enterprise Viewer FBX Out-Of-Bounds Indexing Remote Code Execution Vulnerability

ZDI-15-530
ZDI-CAN-2984

CVE ID CVE-2015-8030
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS SAP
AFFECTED PRODUCTS 3D Visual Enterprise Viewer
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of SAP 3D Visual Enterprise Viewer. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of FBX files. The issue lies in the failure to ensure that index values are within the bounds of an allocated array. An attacker can leverage this vulnerability to execute arbitrary code within the context of the current process.

VENDOR RESPONSE SAP states:


The vendor advised ZDI that the patch and notes will be visible to customers on 13th of October 2015.


DISCLOSURE TIMELINE
  • 2015-06-02 - Vulnerability reported to vendor
  • 2015-10-20 - Coordinated public release of advisory
CREDIT Steven Seeley of Source Incite
BACK TO ADVISORIES