Advisory Details

October 20th, 2015

SAP 3D Visual Enterprise Viewer Flic Animation Heap Buffer Overflow Remote Code Execution Vulnerability

ZDI-15-531
ZDI-CAN-2977

CVE ID CVE-2015-8028
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS SAP
AFFECTED PRODUCTS 3D Visual Enterprise Viewer
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 20142. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of SAP 3D Visual Enterprise Viewer. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of Flic Animation documents. With a specially crafted Flic document, an attacker can trigger a heap buffer overflow condition. An attacker can leverage this vulnerability to execute arbitrary code under the context of the current process.

VENDOR RESPONSE SAP states:


The vendor advised ZDI that the patch and notes will be visible to customers on 13th of October 2015.


DISCLOSURE TIMELINE
  • 2015-07-02 - Vulnerability reported to vendor
  • 2015-10-20 - Coordinated public release of advisory
CREDIT Steven Seeley of Source Incite
BACK TO ADVISORIES