Advisory Details

November 2nd, 2015

Hewlett-Packard Vertica Remote Command Execution Vulnerability

ZDI-15-535
ZDI-CAN-2914

CVE ID CVE-2015-6867
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Hewlett-Packard
AFFECTED PRODUCTS Vertica
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 19853. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett-Packard Vertica. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the vertica-udx-zygote process, which listens on a random port in the ephemeral range. This process accepts an unauthenticated command packet to execute an arbitrary command under the context of dbadmin.

ADDITIONAL DETAILS Hewlett-Packard has issued an update to correct this vulnerability. More details can be found at:
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay/?docId=emr_na-c04873095
DISCLOSURE TIMELINE
  • 2015-05-06 - Vulnerability reported to vendor
  • 2015-11-02 - Coordinated public release of advisory
CREDIT kjczi
BACK TO ADVISORIES