Advisory Details

December 2nd, 2015

Unitronics UniDownloader IPWorksSSL.HTTPS.1 ActiveX Control SSLCertHandle Property Remote Code Execution Vulnerability

ZDI-15-575
ZDI-CAN-2930

CVE ID CVE-2015-7905
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Unitronics
AFFECTED PRODUCTS UniDownloader
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Unitronics UniDownloader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within processing of the SSLCertHandle property of the IPWorksSSL.HTTPS ActiveX control. A crafted value can cause system software to treat arbitrary memory as a certificate structure which is then modified. An attacker can leverage this to attain remote code execution under the context of the user.

ADDITIONAL DETAILS Unitronics has issued an update to correct this vulnerability. More details can be found at:
https://ics-cert.us-cert.gov/advisories/ICSA-15-274-02
DISCLOSURE TIMELINE
  • 2015-05-20 - Vulnerability reported to vendor
  • 2015-12-02 - Coordinated public release of advisory
CREDIT Andrea Micalizzi (rgod)
BACK TO ADVISORIES