Advisory Details

May 10th, 2016

Adobe Acrobat Pro DC WillClose JavaScript API Restrictions Bypass Remote Code Execution Vulnerability

ZDI-16-310
ZDI-CAN-3491

CVE ID CVE-2016-1062
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Acrobat Pro DC
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 23711. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to bypass API restrictions on vulnerable installations of Adobe Acrobat Pro DC. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the WillClose event. By creating a specially crafted PDF with a specific WillClose event, it is possible to bypass the Javascript API restrictions. A remote attacker could exploit this vulnerability to execute arbitrary code.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
https://helpx.adobe.com/security/products/acrobat/apsb16-14.html
DISCLOSURE TIMELINE
  • 2016-01-05 - Vulnerability reported to vendor
  • 2016-05-10 - Coordinated public release of advisory
CREDIT AbdulAziz Hariri - HPE Zero Day Initiative
BACK TO ADVISORIES