Advisory Details

June 3rd, 2016

Hewlett Packard Enterprise LoadRunner Shared Memory Name Construction Remote Code Execution Vulnerability

ZDI-16-363
ZDI-CAN-3516

CVE ID CVE-2016-4359
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS LoadRunner
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 23800. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett Packard Enterprise LoadRunner. Authentication is not required to exploit this vulnerability.

The specific flaw exists within mchan.dll when constructing a shared memory file name. The issue lies in the failure to validate the size of a user-supplied string prior to copying it to a stack-based buffer. An attacker can leverage this vulnerability to execute arbitrary code under the context of the current process.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://h20566.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c05157423
DISCLOSURE TIMELINE
  • 2016-01-26 - Vulnerability reported to vendor
  • 2016-06-03 - Coordinated public release of advisory
CREDIT Tenable Network Security
BACK TO ADVISORIES