Advisory Details

November 2nd, 2016

Hewlett Packard Enterprise System Management Homepage SSO TKN Stack Buffer Overflow Remote Code Execution Vulnerability

ZDI-16-588
ZDI-CAN-3730

CVE ID CVE-2016-4396
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Hewlett Packard Enterprise
AFFECTED PRODUCTS System Management Homepage
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Hewlett Packard Enterprise System Management Homepage. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of /proxy/sso requests. When parsing the TKN parameter, the process copies user-supplied data into a fixed-length stack buffer. A remote attacker can leverage this vulnerability to execute remote code under the context of the process.

ADDITIONAL DETAILS Hewlett Packard Enterprise has issued an update to correct this vulnerability. More details can be found at:
https://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c05320149
DISCLOSURE TIMELINE
  • 2016-05-09 - Vulnerability reported to vendor
  • 2016-11-02 - Coordinated public release of advisory
CREDIT Tenable Network Security
BACK TO ADVISORIES