Advisory Details

March 30th, 2017

Trend Micro InterScan Web Security Virtual Appliance transparent_setting CRLF Injection Authentication Bypass Vulnerability

ZDI-17-233
ZDI-CAN-4437

CVE ID
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Trend Micro
AFFECTED PRODUCTS InterScan Web Security Virtual Appliance
VULNERABILITY DETAILS


This vulnerability allows remote attackers to bypass authentication on vulnerable installations of Trend Micro InterScan Web Security Virtual Appliance. Authentication is not required to exploit this vulnerability.

The specific flaw exists within transparent_setting. The issue results from the lack of proper validation of a user-supplied string before using it to modify a system configuration file. An attacker can leverage this vulnerability to bypass system authentication.

VENDOR RESPONSE Trend Micro has issued an update to correct this vulnerability. More details can be found at:
https://success.trendmicro.com/solution/1116960
DISCLOSURE TIMELINE
  • 2017-01-19 - Vulnerability reported to vendor
  • 2017-03-30 - Coordinated public release of advisory
CREDIT Steven Seeley of Source Incite
BACK TO ADVISORIES