Advisory Details

May 18th, 2017

(Pwn2Own) Apple Safari Spread Operator Integer Overflow Remote Code Execution Vulnerability

ZDI-17-358
ZDI-CAN-4582

CVE ID CVE-2017-2536
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS Safari
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Apple Safari. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of the spread operator. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code under the context of the current process.

VENDOR RESPONSE Apple has issued an update to correct this vulnerability. More details can be found at:
https://support.apple.com/en-us/HT207804
DISCLOSURE TIMELINE
  • 2017-03-17 - Vulnerability reported to vendor
  • 2017-05-18 - Coordinated public release of advisory
CREDIT Samuel Groß and Niklas Baumstark
BACK TO ADVISORIES