Advisory Details

February 27th, 2018

Trend Micro Maximum Security Regex Matching Use-After-Free Remote Code Execution Vulnerability

ZDI-18-216
ZDI-CAN-4911

CVE ID CVE-2016-1699
CVSS SCORE 9.3, (AV:N/AC:M/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Trend Micro
AFFECTED PRODUCTS Maximum Security
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Trend Micro Maximum Security. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.
The specific flaw exists within the analysis of web pages. By performing actions in script matching a large array against a RegEx, an attacker can cause a pointer to be reused after it has been freed. An attacker can leverage this vulnerability to execute code under the context of SYSTEM.

ADDITIONAL DETAILS Trend Micro has issued an update to correct this vulnerability. More details can be found at:
https://esupport.trendmicro.com/en-us/home/pages/technical-support/1119392.aspx
DISCLOSURE TIMELINE
  • 2017-10-20 - Vulnerability reported to vendor
  • 2018-02-27 - Coordinated public release of advisory
  • 2018-02-27 - Advisory Updated
CREDIT Anonymous
BACK TO ADVISORIES