Advisory Details

June 7th, 2018

Qemu Slirp Networking Heap-based Buffer Overflow Privilege Escalation Vulnerability

ZDI-18-567
ZDI-CAN-5588

CVE ID CVE-2018-11806
CVSS SCORE 3.7, (AV:L/AC:H/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Qemu
AFFECTED PRODUCTS Qemu
VULNERABILITY DETAILS


This vulnerability allows local attackers to execute arbitrary code on vulnerable installations of Qemu. An attacker must first obtain the ability to execute code on the guest OS in order to exploit this vulnerability.

The specific flaw exists within the handling of the slirp networking. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code under the context of current user in the host OS.

VENDOR RESPONSE Qemu has issued an update to correct this vulnerability. More details can be found at:
https://bugzilla.redhat.com/show_bug.cgi?id=1586245
DISCLOSURE TIMELINE
  • 2018-04-27 - Vulnerability reported to vendor
  • 2018-06-07 - Coordinated public release of advisory
  • 2018-06-07 - Advisory Updated
CREDIT jskz
BACK TO ADVISORIES