Advisory Details

August 4th, 2020

NETGEAR R6700 httpd strtblupgrade Format String Remote Code Execution Vulnerability

ZDI-20-935
ZDI-CAN-9755

CVE ID CVE-2020-15634
CVSS SCORE 6.3, (AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
AFFECTED VENDORS NETGEAR
AFFECTED PRODUCTS R6700
VULNERABILITY DETAILS

This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR R6700 routers. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the handling of string table file uploads. The issue results from the lack of proper validation of a user-supplied string before using it as a format specifier. An attacker can leverage this vulnerability to execute code in the context of the web server.

ADDITIONAL DETAILS NETGEAR has issued an update to correct this vulnerability. More details can be found at:
https://kb.netgear.com/000062126/Security-Advisory-for-Pre-Authentication-Command-Injection-on-R6700v3-PSV-2020-0189
DISCLOSURE TIMELINE
  • 2020-04-08 - Vulnerability reported to vendor
  • 2020-08-04 - Coordinated public release of advisory
CREDIT d4rkn3ss from VNPT ISC
BACK TO ADVISORIES