Advisory Details

June 25th, 2021

Apple macOS CoreText TTF Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability

ZDI-21-758
ZDI-CAN-13172

CVE ID CVE-2021-1772
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS Apple
AFFECTED PRODUCTS macOS
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of Apple macOS. Interaction with the CoreText library is required to exploit this vulnerability but attack vectors may vary depending on the implementation.

The specific flaw exists within the parsing of TTF fonts. A crafted TTF font can trigger an overflow of a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS Apple has issued an update to correct this vulnerability. More details can be found at:
https://support.apple.com/HT212147
DISCLOSURE TIMELINE
  • 2021-02-10 - Vulnerability reported to vendor
  • 2021-06-25 - Coordinated public release of advisory
  • 2021-06-25 - Advisory Updated
CREDIT Mickey Jin (@patch1t) of Trend Micro
BACK TO ADVISORIES