Advisory Details

August 3rd, 2022

ICONICS GENESIS64 GraphWorX64 TDFX File Parsing Deserialization Of Untrusted Data Remote Code Execution Vulnerability

ZDI-22-1043
ZDI-CAN-16253

CVE ID CVE-2022-33315
CVSS SCORE 7.8, (AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H)
AFFECTED VENDORS ICONICS
AFFECTED PRODUCTS GENESIS64
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of ICONICS GENESIS64. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the parsing of TDFX files. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current process.

ADDITIONAL DETAILS ICONICS has issued an update to correct this vulnerability. More details can be found at:
https://www.cisa.gov/uscert/ics/advisories/icsa-22-202-04
DISCLOSURE TIMELINE
  • 2022-04-14 - Vulnerability reported to vendor
  • 2022-08-03 - Coordinated public release of advisory
CREDIT Alex Birnberg of Zymo Security
BACK TO ADVISORIES