Advisory Details

June 6th, 2024

Trend Micro Maximum Security coreServiceShell Link Following Local Privilege Escalation Vulnerability

ZDI-24-576
ZDI-CAN-22269

CVE ID CVE-2024-32849
CVSS SCORE 7.8, AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
AFFECTED VENDORS Trend Micro
AFFECTED PRODUCTS Maximum Security
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Trend Micro Maximum Security. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the coreServiceShell. By creating a symbolic link, an attacker can abuse the service to delete a file. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of SYSTEM.

ADDITIONAL DETAILS Trend Micro has issued an update to correct this vulnerability. More details can be found at:
https://helpcenter.trendmicro.com/en-us/article/tmka-19175
DISCLOSURE TIMELINE
  • 2024-01-14 - Vulnerability reported to vendor
  • 2024-06-06 - Coordinated public release of advisory
CREDIT Nicholas Zubrisky and Michael DePlante (@izobashi) of Trend Micro's Zero Day Initiative
BACK TO ADVISORIES