Advisory Details

June 18th, 2024

PaperCut NG generateNextFileName Directory Traversal Remote Code Execution Vulnerability

ZDI-24-781
ZDI-CAN-22328

CVE ID CVE-2024-1654
CVSS SCORE 7.2, AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
AFFECTED VENDORS PaperCut
AFFECTED PRODUCTS NG
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on affected installations of PaperCut NG. Authentication is required to exploit this vulnerability.

The specific flaw exists within the generateNextFileName method. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to execute code in the context of SYSTEM.

ADDITIONAL DETAILS PaperCut has issued an update to correct this vulnerability. More details can be found at:
https://www.papercut.com/kb/Main/Security-Bulletin-March-2024
DISCLOSURE TIMELINE
  • 2024-02-18 - Vulnerability reported to vendor
  • 2024-06-18 - Coordinated public release of advisory
  • 2024-07-01 - Advisory Updated
CREDIT Ahmed Y. Elmogy
BACK TO ADVISORIES