Advisory Details

September 8th, 2006

Ipswitch Collaboration Suite SMTP Server Stack Overflow Vulnerability

ZDI-06-028
ZDI-CAN-067

CVE ID CVE-2006-4379
CVSS SCORE
AFFECTED VENDORS Ipswitch
AFFECTED PRODUCTS IMail
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 4496. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Ipswitch Collaboration Suite and IMail. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the SMTP daemon. A lack of bounds checking during the parsing of long strings contained within the characters '@' and ':' leads to a stack overflow vulnerability. Exploitation can result in code execution or a denial of service.

ADDITIONAL DETAILS Ipswitch has issued an update to correct this vulnerability. More details can be found at:
http://www.ipswitch.com/support/imail/releases/im20061.asp
DISCLOSURE TIMELINE
  • 2006-06-22 - Vulnerability reported to vendor
  • 2006-09-08 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES