Advisory Details

February 11th, 2008

Adobe Acrobat Javascript for PDF Integer Overflow Vulnerability

ZDI-08-004
ZDI-CAN-262

CVE ID CVE-2008-0726
CVSS SCORE
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Acrobat
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 5941. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Adobe Acrobat and Adobe Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious web address or open a malicious file.

The specific flaw exists in the parsing of embedded JavaScript code within PDF documents. When the function printSepsWithParams() is called with certain malicious parameter values an integer overflow can occur resulting in a memory corruption. This may be subsequently leveraged to execute arbitrary code under the privileges of the current user.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
http://www.adobe.com/support/security/advisories/apsa08-01.html
DISCLOSURE TIMELINE
  • 2007-11-14 - Vulnerability reported to vendor
  • 2008-02-11 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES