Advisory Details

January 12th, 2010

Oracle Secure Backup observiced.exe Remote Code Execution Vulnerability

ZDI-10-002
ZDI-CAN-471

CVE ID CVE-2010-0072
CVSS SCORE 10.0, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Oracle
AFFECTED PRODUCTS Secure Backup
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Oracle Secure Backup. Authentication is not required to exploit this vulnerability.

The specific flaw exists in the Oracle Secure Backup Services daemon observiced.exe listening on TCP port 10000 by default. Due to the lack of bounds checking on the reverse lookup of connections to the port a stack-based buffer overflow can occur leading to a complete compromise of the affected system under the credentials of the SYSTEM account.

ADDITIONAL DETAILS Oracle has issued an update to correct this vulnerability. More details can be found at:
http://www.oracle.com/technology/deploy/security/critical-patch-updates/cpujan2010.html
DISCLOSURE TIMELINE
  • 2009-04-20 - Vulnerability reported to vendor
  • 2010-01-12 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES