Advisory Details

June 1st, 2010

Novell ZENworks Configuration Management Preboot Service Remote Code Execution Vulnerability

ZDI-10-090
ZDI-CAN-679

CVE ID
CVSS SCORE 10.0, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS Novell
AFFECTED PRODUCTS Zenworks
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 9755. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS

This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Novell ZENworks. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the Preboot Service (novell-pbserv.exe). This service listens for incoming connections on TCP port 998. The service uses a simple binary protocol where the first DWORD is an opcode followed by the specific opcode's data, typically in length/value pairs. These length values are not checked against the destination buffers size allowing for stack-based overflows to occur. This can lead to arbitrary code execution in the context of the SYSTEM user.

ADDITIONAL DETAILS Novell has issued an update to correct this vulnerability. More details can be found at:
http://www.novell.com/support/search.do?cmd=displayKC&docType=kc&externalId=7005572&sliceId=1&docTypeID=DT_TID_1_1&dialogID=138523325&stateId=0%200%20138517923
DISCLOSURE TIMELINE
  • 2010-02-09 - Vulnerability reported to vendor
  • 2010-06-01 - Coordinated public release of advisory
CREDIT Stephen Fewer of Harmony Security (www.harmonysecurity.com)
BACK TO ADVISORIES