Advisory Details

June 27th, 2012

IBM Cognos tm1admsd.exe Multiple Operations Remote Code Execution Vulnerabilities

ZDI-12-101
ZDI-CAN-1418

CVE ID CVE-2012-0202
CVSS SCORE 10, (AV:N/AC:L/Au:N/C:C/I:C/A:C)
AFFECTED VENDORS IBM
AFFECTED PRODUCTS Cognos
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of IBM Cognos. Authentication is not required to exploit this vulnerability.

The flaw exists within the tm1admsd.exe component. This process listens on TCP port 5498 by default. Requests to the service include a request type field, a data length field, and a data field. Multiple request types (opcodes) fail to validate user supplied length and data fields before copying their contents to a fixed length buffer on the stack. A remote attacker can exploit this vulnerability to execute arbitrary code under the context of the system.

ADDITIONAL DETAILS IBM has issued an update to correct this vulnerability. More details can be found at:
http://www-01.ibm.com/support/docview.wss?uid=swg21590314
DISCLOSURE TIMELINE
  • 2011-11-21 - Vulnerability reported to vendor
  • 2012-06-27 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES