Advisory Details

August 22nd, 2012

Cisco AnyConnect VPN Client Arbitrary Program Instantiation Remote Code Execution Vulnerability

ZDI-12-156
ZDI-CAN-1411

CVE ID CVE-2012-2493
CVSS SCORE 9, (AV:N/AC:L/Au:N/C:P/I:P/A:C)
AFFECTED VENDORS Cisco
AFFECTED PRODUCTS AnyConnect VPN Client
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Cisco AnyConnect VPN Client. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists due to insufficient signature checks with the Cisco AnyConnect VPN Client. When the client is invoked through the ActiveX control it downloads and checks a file called vpndownloader.exe. This file has to be properly signed by Cisco. Once this file is downloaded it is run and downloads additional configuration files. Within the downloaded config file it is possible to force a download of executable files. Those files are not properly checked for valid certificates and are run on the host as soon as they are downloaded.

ADDITIONAL DETAILS Cisco has issued an update to correct this vulnerability. More details can be found at:
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco -sa-20120620-ac
DISCLOSURE TIMELINE
  • 2011-11-22 - Vulnerability reported to vendor
  • 2012-08-22 - Coordinated public release of advisory
CREDIT gwslabs.com
BACK TO ADVISORIES