Advisory Details

February 11th, 2013

EMC NetWorker nsrindexd.exe Opcode 0x07 Parsing Remote Code Execution Vulnerability

ZDI-13-019
ZDI-CAN-1543

CVE ID CVE-2012-4607
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS EMC
AFFECTED PRODUCTS NetWorker
TREND MICRO CUSTOMER PROTECTION Trend Micro TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 12746. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of EMC NetWorker. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the way nsrindexd.exe handles RPC calls with opcode 0x07 for program 0x0005F3D9. While processing this message a user supplied string is copied into a fixed size stack buffer. This can result in a buffer overflow which can lead to remote code execution under the context of the current process.

ADDITIONAL DETAILS EMC has issued an update to correct this vulnerability. More details can be found at:
http://www.securityfocus.com/archive/1/525229/30/0/threaded
DISCLOSURE TIMELINE
  • 2012-11-14 - Vulnerability reported to vendor
  • 2013-02-11 - Coordinated public release of advisory
CREDIT Aniway.Anyway@gmail.com
BACK TO ADVISORIES