Advisory Details

February 5th, 2014

Adobe Flash Player Jump Opcode Information Leak Vulnerability

ZDI-14-014
ZDI-CAN-1993

CVE ID CVE-2014-0492
CVSS SCORE 5, (AV:N/AC:L/Au:N/C:P/I:N/A:N)
AFFECTED VENDORS Adobe
AFFECTED PRODUCTS Flash Player
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Adobe Flash Player. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file.

The specific flaw exists within the handling of the jump operation code. The issue lies in the failure of the ActionScript Virtual Machine to properly sanitize values before jumping to them. An attacker can leverage this vulnerability to leak addresses from Flash.ocx within the current process.

ADDITIONAL DETAILS Adobe has issued an update to correct this vulnerability. More details can be found at:
http://helpx.adobe.com/security/products/flash-player/apsb14-02.html
DISCLOSURE TIMELINE
  • 2013-10-23 - Vulnerability reported to vendor
  • 2014-02-05 - Coordinated public release of advisory
CREDIT Anonymous
BACK TO ADVISORIES