Advisory Details

February 13th, 2014

GE Proficy CIMPLICITY CimWebServer File Upload Remote Code Execution Vulnerability

ZDI-14-016
ZDI-CAN-1623

CVE ID CVE-2014-0751
CVSS SCORE 6.8, (AV:N/AC:M/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS GE
AFFECTED PRODUCTS Proficy CIMPLICITY
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of GE Proficy CIMPLICITY. Authentication is not required to exploit this vulnerability.

The specific flaw exists within the CimWebServer component. This component performs insufficient parameter validation on the szScreen field. Successful exploitation will allow an attacker to upload and execute an arbitrary file on the target server.

ADDITIONAL DETAILS GE has issued an update to correct this vulnerability. More details can be found at:
http://ics-cert.us-cert.gov/advisories/ICSA-14-023-01
DISCLOSURE TIMELINE
  • 2013-02-22 - Vulnerability reported to vendor
  • 2014-02-13 - Coordinated public release of advisory
CREDIT ZombiE and amisto0x07
BACK TO ADVISORIES